Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 13, 2025 - 10:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 11, 2025 - 06:06 UTC
Scheduled
Dear Jobpac Connect Customers,
Please be advised of an upcoming scheduled maintenance window to install a patch for Trimble ID. This update is crucial for ensuring a smooth rollout of Trimble ID.
Date: Saturday, 13 September 2025
Time: Starting at 8:00 PM AEST
Duration: Approximately 2 hours during which the system will be unavailable.
We have taken all necessary precautions to ensure a smooth update with no impact on your data.
Thank you for your understanding and cooperation.
Best regards,
The Trimble Jobpac Connect Team
Posted Sep 11, 2025 - 04:49 UTC
This scheduled maintenance affected: Australia / New Zealand (Jobpac Connect).